Dead Electrics

Moderators: ElbowNi, Geezer, NICK, Tony, mikey 69

Dead Electrics

Postby parky » Thu Jul 20, 2017 7:22 pm

My 2T scoot has been laid up (indoors) for 12 months as I was having some body repairs done by a friend of mine. I have now bought a new battery and fitted it but there seems to be none of the electrics now working. Currently the indicators are not connected as I have sent off for some new ones, so could this have anything to do with the lack of electrics? Any advice would be greatly appreciated as I would like to get it up and running asap Thanks
parky
Member
 
Posts: 97
Joined: Tue Apr 27, 2010 6:45 pm
Location: Plymouth

Re: Dead Electrics

Postby NICK » Thu Jul 20, 2017 8:06 pm

Have you check the fuse/fuse holder by the battery? Stupid question but is the battery charged? Cheers
NICK
Site Admin
 
Posts: 6439
Joined: Fri Jan 15, 2010 10:24 pm
Location: Cornwall
Scooter: 2006 LML 150 5 PORT (NON REED).Mint Green

Re: Dead Electrics

Postby parky » Thu Jul 20, 2017 8:32 pm

Yes battery charged but not checked fuses. It has been so long since I rode the scoot I cant remember if there is an ignition light which comes on when the key is turned or whether the lights work without the engine running. I haven't tried kicking it over so would the electrics work if the scoot was started up?
parky
Member
 
Posts: 97
Joined: Tue Apr 27, 2010 6:45 pm
Location: Plymouth

Re: Dead Electrics

Postby parky » Fri Jul 21, 2017 11:52 am

All sorted dodgy fuse
parky
Member
 
Posts: 97
Joined: Tue Apr 27, 2010 6:45 pm
Location: Plymouth


Return to General Discussion - Scooter related

Who is online

Users browsing this forum: No registered users and 1 guest